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The GNU TEXMACS project aims to provide a free, polyvalent and user-friendly
editor, which can easily be interfaced with a wide range of external softwares. Spe-
cial attention has been paid to features which are interesting for scientists, such as
a mathematical formula editor, the possibility to write structured texts, a mode for
laptop presentations, etc. Moreover, advanced typesetting algorithms are used,
which allow for the creation of high quality documents. In this paper, we survey
the main features of TEXMACS, taking the point of view of a scientist who wants to
write an article.

1. Introduction

General purpose office suits provide ordinary users of computers with a convenient solu-
tion for most common desktop tasts, such as text editing, drawing pictures or data
administration. Some well-known office suites are Open Office, Microsoft Office

and Star Office. A major challenge is to provide a similar software for scientically
oriented users. Typically, a scientific office suite might offer high quality support for
editing mathematical formulas, performing complex computations, making presentations
from a laptop, collaborative authoring, and so on.

Currently, many mathematicians, physicists and computer scientists use LATEX for
writing papers, Matlab, Mathematica, etc. for doing computations, yet other soft-
wares for drawing technical pictures, Power point for making presentations, etc. This
situation raises endless problems for persons who want to write articles with mathemat-
ical formulas, pictures and computations, especially if the paper is also to be published
on the web and presented from a laptop.

The GNU TEXMACS project [vdH98] aims to provide a solution to these problems in
the form of a “scientific editing platform”. On the one hand, TEXMACS can be thought of
as a scientific office suite in the above sense. On the other hand, the software can easily
be extended: users may write their own style files and customizations of the editor and
developers can add plug-ins with new functionality (extra features of the editor, inter-
faces with other software, etc.).

It should be noticed that TEXMACS is a free software, which is part of the GNU pro-
ject [GNU83]. In a similar way that most scientists insist on the fact that scientific
results should be published in order to deserve credit and that it should be possible to
base new results on older ones, we believe that a similar spirit should be applied to soft-
ware: should a result returned by Mathematica have the same status as a mathemat-
ical proof? If it returns the wrong result, is that an experimental error? Is it normal
that we don’t know what is going on behind the scene?

From the development point of view, and unlike many other softwares, it should be
emphasized that TEXMACS is mainly written by scientists. This has the advantage that
the developers are also users of the software and have a real interest at providing good
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solutions. Moreover, there are several mailing lists where ideas about how to improve
the program are discussed. The open development model also makes it possible for
anyone to contribute as a function of personal skill. Please be aware of the fact that
merely using and advertising the software is already of great importance to us. Of
course, besides the contribution of code, we also welcome donations.

In this paper, we survey the most important features of TEXMACS. Other introduc-
tory texts are [Sei05, Rat05, Gro01, Gro05]. Above all, TEXMACS can be used to write
structured documents with mathematical formulas. As the name suggests, we have been
inspired by the TEX-L

ATEX system [Knu84, Lam94, GMS93] from the typesetting point
of view and the emphasis on content rather than presentation. However, we do believe
that presentation is important during the writing phase. Much like high quality typet-
ting allows the reader to concentrate on what he is reading, a good editor should allow
the author to concentrate on what is written and not on how it is written. In particular,
TEXMACS does not rely on TEX-L

ATEX, but has been written from scratch to be both
structured and wysiwyg (what-you-see-is-what-you-get). This makes the program more
efficient to learn and use than TEX-L

ATEX, without sacrificing its major advantages.
In sections 2, 3 and 4, we start by explaining how to write a structured document

with mathematical formulas with TEXMACS. In section 5, we discuss conversions of
TEXMACS documents from and to other formats, such as LATEX, Html and MathML.
A full description of the remaining features of TEXMACS would be beyond the scope of
this survey. Nevertheless, section 6 demonstrates how to use TEXMACS as an interface to
computer algebra systems. In section 7, we quickly review some of the other possibilities
offered by the program.

Our website http://www.texmacs.org contains instructions on how to download
and install TEXMACS. When working on a network, it might be that the software has
already been installed by your system administrator. TEXMACS is freely available for all
major platforms, including Windows and MacOS-X. However, if you have the choice,
then we especially recommend the Linux version, since this is the platform on which
TEXMACS is developed. We finally notice that TEXMACS has been used for the creation of
several books [vdH04, Bum04, BPR06] and numerous PhD’s and articles.

2. First steps with TEXMACS

In this section, we start by showing how to create a new paper. After launching the pro-
gram, you may first choose a document style and language in the menus Document →
Style and Document → Language. When selecting the article style (for instance), a title
can be inserted using Text → Title → Insert title. After entering the title, followed by
return , you may next enter your name (followed by return ) and your address. Addi-
tional fields, like the date, an email address, etc. can be entered from the Text → Title

menu.

Figure 1. Illustration of how to enter the title information of an article.

2 GNU TEXMACS
: a scientific editing platform



While entering the title information, you may notice the appearance of a light cyan
box. This box indicates that your cursor is inside a structured environment (in this case
the title). As soon as you finished entering the title information, it suffices to click with
the mouse outside the box (at the right, if there is no line below the title yet) and press
return in order to proceed with the main article.

The user interface of TEXMACS is quite redundant: you usually have three or four
ways to accomplish a given action. For instance, in order to start a section “Introduc-
tion”, you have the following four options:

1. Use the Text→ Section→ Section menu item.

2. In the second icon bar, click on the icon, followed by a click on Section.

3. As in LATEX, type \ s e c t i o n followed by return .

4. Use the keyboard shortcut A-1 , where A- stands for the alt key.

After starting the section, you may enter the title “Introduction” in the light cyan box
and press return when you are finished (or click at the right or below the section title
to move out of the box). It should be noticed that the keyboard shortcut A-1 also
appears in the Text → Section menu; this makes it easy for new users to gradually learn
efficient keyboard shortcuts for most common actions.

Other common markup like enumerations, theorems, etc. can be entered in a similar
way. For instance, you may use Text→ Environment→Theorem or \ t h e o r e m fol-
lowed by return in order to start a new theorem. Notice that one may also apply
markup to the current selection. Example: when selecting a piece of text using the
mouse, you may press on the icon in order to tag the text as being “strong” (which
will make it appear in bold face).

In a similar way as in LATEX, the tags section, theorem, strong allow the user to
structure a document, and invite you to concentrate on intent rather than presentation.
Nevertheless, most tags (and in particular the above ones) have a sufficiently distinctive
presentation for making the structure apparent from the mere rendering of the docu-
ment. Moreover, at the current cursor position, TEXMACS provides the author with addi-
tional information about the structure: the possibly nested cyan boxes indicate the cur-
rently active environments and the status bar provides additional details:

Figure 2. Illustration of the active structure at the current cursor position. The width of the
cursor indicates that we are writing text using a bold type face. The two light cyan boxes and
the right hand side of the status bar indicate that we are writing strong text inside an enumera-
tion. The left hand side of the status bar tells us that we are using an article style and that we
are in text mode, using a bold 10pt Roman text font.
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Remark 1. An analogue of the “LATEX source code” is available in TEXMACS using Doc-

ument→ View→ Edit source tree. However, from our standpoint, there is no real concept
of the “source code”. In reality, documents are trees, which can be rendered in different
ways so as to make certain tags more or less explicit. In particular, the presentation of
the “source code” can be customized using the submenus below Document → View →
Source tags. Furthermore, we consider x

√
to be just as good (and arguably even better)

a “source code” as \sqrt{x}.

Some final remarks are useful for your first meeting with TEXMACS.

• TEXMACS integrates a help system. The F1 -key allows you to search for key-
words in the help files, in a similar way as with Google. When remaining with
your mouse on certain icons or menu entries, a help balloon may pop up with a
succinct description.

• You may save your work under a new name in a similar way as in most text edi-
tors, using File → Save as. In fact, it is recommended to give your text a name
before starting to type it.

• TEXMACS makes heavy use of keyboard modifiers for fast keyboard shortcuts. In
the documentation, the prefixes S- , C- , A- and M- respectively stand for

shift- , ctrl- , alt- and meta- . On many keyboards, meta- corresponds to
the Windows key; if not, then you may use the escape key instead.

• For users of foreign languages, it should be noticed that accented characters can
be obtained by shortcuts of the form M-accent letter . For instance, M-’ e

yields é. On foreign keyboards, the dead keys should work fine too. For more
information, see Help → Manual → Typing simple texts and Help → Configuration

(for Cyrillic and oriental languages).

• You may wish to customize the user interface. Some popular settings are Edit →
Preferences → Look and feel→ Windows and Edit→ Preferences→ Interactive ques-

tions→ In popup windows.

3. Typing mathematics

Special care has been taken so as to make the input of mathematical formulas particu-
larly efficient. As in TEX/L

ATEX, mathematical formulas are entered in “math-mode”; an
inline mathematical formula is inserted by pressing $ and a displayed formula using the
shortcut A-$ . Inside math-mode, the second icon bar contains several buttons for
entering mathematical constructs and symbols:

Figure 3. Illustration of the changes in the front-end inside math-mode. The second icon bar
contains several buttons for entering mathematical constructs and symbols; from left to right: a
fraction, a square root, a general root, an index, a superscript, etc.. Notice that the light cyan
box, the colour of the cursor and the status bar again indicate that we are inside a mathemat-
ical formula.
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Although the icons and/or TEX/L
ATEX commands may be used in math-mode, it is

most efficient to use the specially designed keyboard shortcuts. Most mathematical sym-
bols are obtained using a small set of basic rules:

• Characters which are naturally obtained as “superpositions” or “concatenations” of
symbols on your keyboard are entered in a straightforward way. For instance,
- > yields →, < = yields 6, + - yields ± and < < yields ≪ .

• The “variant” key tab may be used in order to obtain variants of a given symbol
or keyboard shortcut. For instance, < = tab yields ≤ , < = tab tab tab yields
⇐, < tab yields ≺ and < | tab yields ⊳. All Greek letters can be obtained as

variants of the Roman ones: a tab yields α, l tab yields λ and so on. Some-

times, additional variants are available: b tab tab yields ♭ and e tab tab

yields the mathematical constant e.

• The / and @ keys are used for obtaining negations and symbols inside other
symbols. For instance, < = / yields 
 and @ + yields ⊕ . More elaborated

examples are @ tab + and < tab = tab / tab , which yield ⊞ resp. �.

Efficient shortcuts are also available for most mathematical constructs: A-f starts a
fraction, A-s a square root, _ a subscript and ^ a superscript. A big symbol such as
∑

is inserted using S-F5 S and big delimiters as in
(

a

b

)

using A-( and A-) .

Inside a mathematical formula, the cursor keys allow you to move around in a graph-
ically intuitive way. In particular, when done with a particular subformula, it usually
suffices to press → in order to return to the main formula. For instance, assume that
we wish to type the formula

∑

k=1

∞
1
k2

=
p
2

6
.

This is done as follows:

1. Insert a displayed formula using A-$ .

2. Enter the big sum using S-F5 S and its subscript using _ k = 1 .

3. Leave the subscript using → and enter the superscript using ^ @ @ .

4. Leave the superscript using → → and start the fraction using A-f .

5. Enter the numerator 1 , go to the denominator ↓ and enter k2 k ^ 2 (see
figure 4).

6. Leave the superscript and the fraction → → and type = .

7. Enter the right hand fraction using A-f p tab tab ^ 2 ↓ 6 .

8. Leave the fraction → and finish . .

Figure 4. Screenshot of the situation after step 5 in the above example.

Joris van der Hoeven 5



A slightly more involved example shows how to enter the matrix




a1,1 � a1,n
 

an,1 � an,n





1. Insert a displayed formula with a matrix using A-$ \ m a t r i x return .

2. Type the first entry a _ 1 , 1 and insert a new column to the right A-→ .

3. Enter the dots . . tab and the third column A-→ .

4. Enter a1,n a _ 1 , n and start a new row return .

5. Enter the vertical dots . . tab tab tab twice → → . . tab tab tab .

6. Start the third row return .

7. Select the first row with the mouse and position your cursor at the first cell in
the third row (see figure 5).

8. Press the middle mouse button or C-y so as to copy the selection at the current
cursor position.

9. In the last row, change a1,1 and a1,n into an,1 resp. an,n by clicking with the

mouse just behind the 1-s, removing them using backspace and entering the n-s.

Figure 5. Screenshot of the situation after step 7.

4. Further features for typing an article

With what has been said in the previous sections and a bit of goodwill, the reader
should be able to type simple mathematical texts. Let us briefly survey some additional
features of TEXMACS, which are needed in order to type a complete article.

Most importantly, let us describe how to label sections, formulas, etc. and how to
create references. First of all, inside a displayed formula, a section title, a theorem, etc.,
you may use the keyboard shortcut A-* in order to insert or remove a number. Given a
numbered formula, such as

a2 + b2 = c2, (1)

a label for the formula is inserted as follows:

1. Put the cursor at the start of the equation, just before the a.

2. Start a label using M-! .

3. Type the label text “Pythagoras” P y t h a g o r a s (see figure 6).

4. Activate the label by pressing return .
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Notice the difference between the “inactive” state of a label, in which it is possible to
edit the label, and its “active” state, in which it is not visible on paper and indicated by
a small marker on your screen (you may wish to try some alternative renderings from
Document→View→ Informative flags). Notice also that the placement of labels should be
done with care: in the case of equations and theorems, the label is put at the start inside
the environment. However, for section titles, the label should be put just after the title.

Figure 6. Illustration of the inactive label “Pythagoras” after step 3.

Given an active label, a reference to it may be created in a similar way, using M-? .
The name of the reference may be entered efficiently using tab -completion. For
instance, assuming that “Pythagoras” was the only label starting with “Py”, typing
P y tab inside the newly created inactive reference should complete “Py”
into “Pythagoras”. We notice that all references created within TEXMACS are “dynamic”
in the sense that you will jump to the corresponding label when clicking on them. We
also notice that the mechanism of tab -completion applies in other circumstances. For
instance, when entering plain text, you may use tab -completion in order to complete
long words which already occur elsewhere in your text.

Currently, TEXMACS relies on BibTEX for the creation of bibliographies. Citations

are created using \ c i t e return . In case of a multiple citation, additional citations

are inserted using tab . As usual, you should press return in order to activate the
citation. The bibliography is inserted using Text→ Automatic→ Bibliography after which
the user will be prompted for a bibliography style (plain, alpha, etc.) and a bibliog-
raphy file (in BibTEX format). The bibliography can be updated using Document →
Update → All. For more information about how to use BibTEX, we refer to [GMS93,
Lam94].

5. Conversions

Unfortunately, TEXMACS is not yet as wide-spread as LATEX. In particular, publishing
companies do not yet accept TEXMACS as a standard format (even though we invite you
to complain about this, if you like our program). Similarly, when writing joint articles,
not all authors may wish to switch to TEXMACS. For the sake of backward compatability,
TEXMACS provides high quality converters from and to LATEX. However, these converters
cannot be perfect for several reasons.

The main reason is that LATEX is not a format, like Html, but rather a program-
ming language. In particular, the only program which parses all LATEX files correctly is
LATEX itself. Since TEXMACS is not a LATEX front-end, it follows that we can only
ensure correct conversions for a (quite large) sublanguage of LATEX. The other main
reason is that TEXMACS has a more powerful typesetting engine than LATEX and that it
provides several extensions (like a graphical editor or animations) which are not avail-
able in LATEX. Therefore, a conversion to LATEX may downgrade your document, both
in typesetting quality and in structure. For instance, TEXMACS pictures are exported as
postscript images, so their structure is lost.
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Fortunately, for basic texts with mathematics, which do not involve any of the fancy
features of LATEX or TEXMACS, the converters usually work fine. In the case of conver-
sions from TEXMACS to LATEX, one usually just has to modify the document class of the
generated file and enter the title information in the style which is required by the partic-
ular journal to which you submit. The behaviour of the converter may also be cus-
tomized using Edit → Preferences → Converters → TeXmacs -> LaTeX. In particular, we
notice that TEXMACS may put some additional macros in the preamble, so as to increase
the readability of the LATEX conversion. This behaviour may be disabled whenever the
journal to which you submit requires so.

Conversions from LATEX to TEXMACS are slightly more subtle, due to the problems
mentioned above and the fact that some of the macro definitions may be in other files.
Before importing LATEX files, it is therefore a good idea to ensure that all macro defini-
tions have been put in the preamble. If you are lucky, this will enable TEXMACS to cor-
rectly import your file (modulo minor mistakes which are easily corrected by hand). If
not, then you may try to convert your document by smaller pieces. We notice that you
may paste selections of LATEX text into TEXMACS using Edit→Paste from→ LaTeX.

One big advantage of TEXMACS over LATEX is that its document format is clean. In
particular, as TEXMACS gets more users, it is likely that good converters for other for-
mats will be developed. Currently, TEXMACS already admits converters for large parts of
Html/Xhtml and Mathml. Again, the TEXMACS to Html converter can be cus-
tomized using Edit → Preferences → Converters → TeXmacs -> Html and the user may
choose how to export mathematical formulas: as text, as images, or as Mathml. Notice
that you have to use the .xhtml suffix when selecting the last option. An example of
different conversions of the same TEXMACS document is given in [vdH06].

6. Computer algebra sessions

One interesting and unique feature of TEXMACS is its ability to incorporate computer
algebra sessions directly inside the text. When clicking on Insert → Session, you will see
a list of the available systems on your computer which are recognized by TEXMACS.
Some free general purpose systems with TEXMACS interfaces are Maxima and Axiom

[Max98, Axi]. There are also interfaces for some other types of systems, like GNU

Octave (scientific computation), GNU R (statistics), etc. Below, we will demonstrate
some of the functionality of the Maxima interface. Of course, similar principles apply to
other systems.

A new Maxima session is inserted using Insert→ Session→Maxima:

Maxima 5.9.0 http://maxima.sourceforge.net

Distributed under the GNU Public License. See the file COPYING.

Dedicated to the memory of William Schelter.

This is a development version of Maxima. The function bug_report()

provides bug reporting information.

(C1)

At the prompt, you may type Maxima commands:

(C1) diff(x^x^x^x,x);

(D1) xxx
x (

xxx

log x
(

xx log x (log x +1) +xx−1
)

+xxx−1
)

(C2) integrate(d1,x);

(D2) elogxelog xe
xlog x
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After Session → Input mode → Mathematical input, the commands may be entered
nicely, in a two-dimensional way:

(C3) M :

(

x + y y

x− y2 y + z

)

;

(D3)

(

y +x y

x− y2 z + y

)

(C4) determinant(M);

(D5) (y + x) (z + y)− y
(

x− y2
)

As in most computer algebra systems, previous inputs may be modified and re-evalu-
ated. Similarly, it is possible to copy parts of the output back to a new input, which
may even belong to another session (of a potentially different system).

Other facilities for managing sessions are available from the Session menu and the
second icon bar. For instance, Session → Remove fields → Remove all output fields allows
you to remove all output fields from the current session. Also, A-→ or Session→ Insert

fields→ Fold input field allows you to group several inputs and outputs together in a fold-
able portion of text. When working on the screen, this feature is particularly nice in
combination with the varsession package which is selected using Document → Add

package→Program→ varsession.

Some examples of integrals

(C1) integrate
(

sin(x) x5, x);

(D2)
(

5 x4− 60x2 + 120
)

sinx+
(

−x5 + 20x3− 120x
)

cosx

(C3) integrate

(

x5

x2− x+ 11
, x

)

;

(D3)
89 log

(

x2−x + 11
)

2
+

551 arctan
(

2 x − 1

43
√

)

43
√ +

3 x4 +4 x3− 60x2− 252x

12

By clicking on the left bar with the mouse, the user may fold or unfold the group.
For further information and examples on how to use computer algebra sessions from
within TEXMACS, we refer to [Gro05, Gro01]. Some systems, like Maxima, come with a
help system which has been integrated with TEXMACS.

We finally notice that it is also possible to use external systems in a more invisible
way while writing texts. For instance, after selection of Maxima as the “scripting lan-
guage” using Document → Scripts → Maxima, you may use Maxima to evaluate the cur-
rent formula you are typing (or the current selection) by pressing C-return . More func-
tionality is available in the Maxima menu.

7. Other features

7.1. User-defined macros

As in LATEX, the user may define new typesetting constructs or customize the rendering
of the standard styles using a special macro language. For instance, one may define a
macro cd for square commutative diagrams using
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〈assign|cd|〈macro|A|B|C|D|
A → B

↓ ↓
C → D

〉〉

This macro may then be used by typing \ c d return , as in

A⊕B → C

↓ ↓
D → E ⊗F

For more information, we refer to Help → Manual → Writing your own style files and
Help→Reference guide.

7.2. Customizing the interface and Scheme extensions

Following the example of GNU Emacs, the user interface and most of the editing func-
tions of TEXMACS are written in Scheme, a high level “extension language”. This makes
it possible for the user to customize the behaviour of TEXMACS and write extensions to
the editor. Simple customizations can be put in the file my-init-texmacs.scm of the
.TeXmacs/progs subdirectory of your home directory. For instance, assume that this file
contains the following code:

(kbd-map

(:mode in-text?)

("T h ." (make ’theorem))

("D e f ." (make ’definition)))

Then the keyboard shortcuts T h . and D e f . can be used inside text mode in
order to insert a theorem resp. a definition. In a similar way, you may customize the
menus, or add more complex extensions to the editor. For more details, we refer to
Help→ Scheme extensions.

7.3. Editing tools

TEXMACS supports several standard editing facilities (search and replace, a spell checker,
undo/redo and tab -completion), as well as some more original “structured editing”
tools. We have already seen that the keyboard shortcut A-* may be used to toggle the

numbering of sections, equations, etc. Similarly, the shortcut C-tab enables the user to
circle among a finite number of “structured variants” of the innermost environment. For
instance, inside a theorem, C-tab will turn the theorem into a proposition, a lemma
and so on. The structure of the text may also be used for accelerated navigation. For
instance, when you are inside an environment, then C-pagedown will move to the next
environment of a similar kind. This allows you to quickly jump from a section title or a
theorem to the next one. For more information about the editing tools, we refer to
Help→Manual→Editing tools.

7.4. Presentation mode

Besides writing articles, TEXMACS can also be used for making presentations from
a laptop. The presentation mode is enabled using View→ Presentation mode. In general,
you may want to select Document → Style → seminar and Document → Page → Type →
Automatic, when making presentations. The Insert → Fold and Insert→ Animation menus
contain several entries which are particularly useful for making nice presentation
(another interesting application of these menus is the creation of interactive books).
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When making a presentation, you usually start by creating a switch (Insert→ Fold→
Switch → Screens). Successive “screens” for the presentation can be inserted using
Insert→ Fold→ Switch→ Insert branch after. In presentation mode, you may then use the
keys F9 , F10 , F11 and F12 to switch to the first, previous, next, resp. last screen.
Inside each screen, you may recursively insert other switches or foldable markup and
control more precisely what happens when pressing F10 or F11 .

7.5. Technical pictures

External pictures can be included inside a document using Insert→ Image→ Insert image

or Insert→ Image→ Link image. In the first case, the image is included into the main file;
in the second case, we refer to the image file by a link. TEXMACS also includes a native
editor for drawing simple technical pictures. One advantage of this integrated drawing
tool is that it is easy to include mathematical formulas or other TEXMACS markup inside
the picture. One may use Insert → Image → Draw image to start a new drawing and
Insert → Image → Draw over selection to draw a picture on top of the current selection
(typically an external picture, or a mathematical formula).

31

3

2

1 g(x) = (3 +x)/4

f(x)= 1− 1−x2
√

0

Figure 7. Toy example of a technical picture created with the drawing tool.

7.6. Typed hyperlinks and actions

Hyperlinks and actions provide another way to make texts or presentations more lively.
Basic hyperlinks and actions can be inserted using Insert → Link → Hyperlink resp.
Insert → Link → Action. In the case of an action, the target is a scheme command. For
instance, after activation, the action below allows you to launch an xterm by clicking
on “here”.

Click 〈action|here|(system "xterm &")〉 to launch an xterm.

When enabling the “linking tool” using Edit→ Preferences→ Utilities, it becomes pos-
sible to create more complex typed links (or actions) between portions of texts. For
instance, a given theorem may be linked both to one an example and a remark. More-
over, links are bidirectional by default, which makes it possible to jump back from the
example or remark to the theorem.

8. Conclusion

In the decades to come, it can be expected that the nature of scientific publications will
change dramatically so as to allow for more and more interactivity. On the one hand
side, more and more tools for specific tasks (computations, drawing graphs, remote con-
nections, etc.) should become available. On the other hand, it will become increasingly
difficult to design high quality interfaces for such individual softwares from scratch.
Moreover, the use of incompatible data formats and editing conventions tends to make it
more and more difficult for users to combine several tools in a natural way.
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We hope that TEXMACS provides an attractive solution to these problems, both for
users and developers. On the one hand, TEXMACS already provides a wide variety of uni-
form and high quality editing tools for structured texts, mathematics, graphics, presen-
tations, linking, etc. which can be combined in a natural way. On the other hand, we
provide a framework for developers to create extensions and interfaces to external soft-
ware.

In the case that our approach pleases you, we finally notice that you can obtain addi-
tional information or help by subscribing to one of our mailing lists:

http://www.texmacs.org/tmweb/home/ml.en.html

TEXMACS is still under active development and there are many plans for improvements
and new features, such as remote web-connections, version control, interactive books,
a spreadsheet, literate programming, etc.
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